Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Desperately require help installing/opening Unity! Package Manager problem!

Alrighty, so, first of all, thanks for clicking~!

I’ve had to rewrite this quite a lot of times, as I kept making new discoveries (And old ones were proven wrong, and the sort), but now I think this is close to the best I can do.

I hugely appreciate every last tidbit of help or advice!

On my own, I’m kinda stuck here, for now.


WHAT HAPPENS?

- I open Unity Hub

- I create a New Project (Unity 2019.3.15f1, and had the same issues with Unity 2019.4.1f1)

- 2D/3D (Either produces the same result)

-Project creation process runs smoothly until “Starting Server” (Progress bar stuck)

-Error message


These are my two lovely error messages I’m getting:

Antivirus error:


IP Address error:


After a lot of inspecting and testing out, I thought I had finally figured out a pattern in the error, being the Antivirus error popping up once after turning Avast Antivirus, then being replaced by the IP Address error.

However, it turns out that doesn’t quite seem to be the case, as the IP Address error will sometimes pop up instead of the expected Antivirus one.


Something I have found out, though, is that if the Antivirus error doesn’t pop up, it’s the IP Address one, so I’m thinking the IP Address one is sort of like a “last line of defense” (If that makes sense, didn’t know how to explain it differently ^^’).


Additionally, it seems whenever I “Quit Unity Hub”, then reopen it, the version I used when creating the projects is shown as “Unavailable”:



WHAT HAVE I TRIED?

- Reinstalling Unity Hub (And with both Firewall + Avast Antivirus off)

- Reinstalling Unity 2019.3.15f1 (And Unity 2019.4.1f1) (Also with both Firewall + Avast Antivirus off)

- Running Unity Hub as Administrator (And with Firewall + Avast Antivirus off)

- Running Unity 2019.3.15f1 with Firewall + Avast Antivirus off

- Activating all of the “Inbound Rules” related to Unity (I’ll add a picture of it further below)

- Creating a new “Inbound Rule” to allow connection to the IP Address “127.0.0.1” (Picture further below)

- Adding “UnityPackageManager.exe” to the built-in Windows Firewall’s list of programs that are allowed through it (Now I have 7 “Node.js:Server-side JavaScript”s on the list of allowed programs, which is a little strange)

-Adding the following to my Avast Antivirus’ list of files/folders/websites to exclude from its shields/scans:

-UnityPackageManager.exe

-Unity Editor (2019.3.15f1) (Currently only using 2019.3.15f1)

-Unity Hub.exe

-D:\unity's birth temp\2019.3.15f1\editor\data\resources\packagemanager\diagnostics\bin\*

-http://127.0.0.1/*

-(And for the following, both “http” and “https”)

    -http://upm-cdn.unity.com/*

    -http://akamai.bintray.com/*

    -http://api.bintray.com/*

    -http://dl.bintray.com/*

    -http://download.packages.unity.com/*

    -http://packages.unity.com/*





WHAT I THINK MAY BE POSSIBLE REASONS

- I am unable to use my Product Key to activate Windows (Windows 7 Professional as the version, and it’s a long story), thus my Windows copy hasn’t been confirmed to be legitimate

(Maybe that has an effect on this whole thing?)

- I am positive it has something to do with Unity 2019’s newer Package Manager (I think I’d read that there was a change from the previous version), as 2018 opens totally fine




ATTACHMENTS

-Unity Inbound Rules (Please don’t mind the German, I assure you they’re all activated and set to “Allow Connection”) (Also, those are quite a lot of the same rules, maybe that has something to do with it, but in that case, Unity probably would have worked the first time, I suppose?)



-Self-made Inbound Rule for IP Address (Note: I haven’t deleted the original, already-made rule yet (Of which the one I’ve made is an exact copy), so maybe I need to do that?)




Apologies if I’ve forgotten to add anything, it’s been over a month since I’ve started trying to get this to work.

Thank you so much for reading this pretty long post!

I am honestly unbelievably thankful for any and all help you have to offer!

Best Answer

  • JellyCOREJellyCORE Member
    edited July 11 Accepted Answer

    SOLUTION HAS BEEN FOUND!

    I wanted to make this comment for anyone who might have the same problem!

    WHAT WAS THE PROBLEM?

    The problem was my unregistered Windows 7 Professional copy. Likely because I couldn't install the required updates as shown in an image below, Unity 2019's Package Manager would not work.

    WHAT WAS MY SOLUTION?

    I decided to try my luck purchasing a copy of Windows that COULD be registered/activated.

    Since Windows 7 has now been unsupported by Microsoft since January, I decided to buy a copy of Windows 10 Home (I actually had the EXACT amount saved up, my god XD).

    This has worked! I am inexplicably happy! I can finally truly begin Game Development, which is very likely my largest passion ;W;

    UNITY INSTALLATION SUCCESSFUL!!

Answers

  • maddymaddy Member

    try a bit lower version of unity...like 2018 ...maybe it'll help

  • Heya! Thanks for your response!

    I've tried Unity 2018.4.23f1, and that opens A-OK!

    I'd just really like to be able to use 2019, as well, and figure out how to solve this issue. ^^'

    Thanks for your time!

  • This was originally just gonna be a bump, but I decided to make it more of a meaningful addition!

    So, here's something I forgot to add!

    I don't know how important it is, but there's a notice at the bottom of Unity Hub that tells me to make sure I have two things installed, two things that can apparently be installed through Windows Updates!

    However, as stated above, I cannot really do any Windows Updates, unfortunately.

    Anyway, here's today's contribution!


  • Bump~

  • Bump for today~!

  • Aaaand bump~!

Sign In or Register to comment.