Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Unity game view and script problem [Cube Game Tutorial]

I was following the tutorial of Cube Game,

so the problem that i am facing is that when i run game (not in game view) the controls work fine, but as soon as i run the game in game-view mode ; the player just moves forward but the left and right controls are not responding. I have some solutions online it doesn't work.

There is also a another problem; that everytime i start my game in unity for the first time, the code for controls doesn't respond, i have to go into the code and have to make some changes, and the changes are basically me adding a space anywhere so that i can save the project and the unity will refresh itself to take the "changed code" ...and after all that-THEN the game runs fine, even then once i move to game view the game doesn't respond to control.

Accepting proper responses.


  • Just go to game view, click on maximise to play button, exit game view and then press play button. Your 1st problem should be solved.

    I can't say anything about your 2nd problem.

    I hope this helps 😁

Sign In or Register to comment.