Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Why I am getting "Invalid expression term 'int' " and the name 'i' does not exist in the current" ?

Best Answer

  • mememe09876mememe09876 Member
    Accepted Answer

    you got wrong at line 13

    for (int 1 = 0; i < movie.Length; i++)

    it must be

    for (int i = 0; i < movie.Length; i++)

Answers

  • Have you gotten further already? I am getting into arrays Today only got to finish classes in sololearn yesterday so i am sorry for my noobness.


    Well for the first error my guess would be to leave out the "int" at Line 13 so write for(1 = 0; i <...).

    For the other errors i might be able to help out later.

    Pleas tell me if my first idea worked out and if not and you found out what fixed it thanks :)

  • kpman23kpman23 Member
    edited October 2020

    I am a noob as well and it's nothing to feel sorry about it. And for solution, I haven't found anything actually but I believe those kind of problems can be ignored because if I press "Debug anyways" it works perfectly fine. I just don't feel right when they show up, you know "annoying".

    I you don't have any problem, I would like us to be in contact so we can help out each other.

  • kpman23kpman23 Member
    edited October 2020

    Why this occured ??


    EDIT: Sorry! I panicked a lot. You actually need an external terminal to get rid of this.

    Hope this is helpful. 😉

  • Hi,

    so im confused of what your problem is but the only thing is see wrong that there is no true in ReadKey();


    Write it like this: Console.ReadKey(true);


    If this didn't fix your problem tell me :)


    Greetings, Islu Terras 👽️

  • Oh and yes i am always happy to be contacted for help. Can't promise an answer tho i have a lot to do.

    :) :)

Sign In or Register to comment.