Unity build will not work with Android

Updated on June 11, 2019 in [A] Unity Scripting
Share on Facebook0Tweet about this on TwitterShare on Google+0Share on Reddit0
4 on June 6, 2019

Hey

I am working on trying to release an app for the google play and app store. But when I build the app out to my android phone which is a Samsung galaxy s6 edge I get the splash screen and then nothing else. Every time I try even launching the app form the phone it still gives me a black screen after the splash screen. I did try and build the app out to my iPhone which is iPhone X and it works just fine. The splash screen loads and then my main menu loads without any problems. I am really at a loss on what I need to do to fix it. If anybody has any suggestions that would be great.

 

Thanks!

  • Liked by
Reply
3 on June 6, 2019

could you post your build setting, and your player settings > other setting please.

Are you building with Gradle or Internal?

on June 9, 2019
Wise
on June 10, 2019

OK, try setting your minimum API to 7.0 ‘Nouget’ API 24, I think Google requires at least API 20+ to go to the store. Switch your build settings from Internal to Gradle. I had a similar problem building to the Oculus Go, where it would just splash screen and then stop. Google may also require you to build with Gradle anyway.

Last thing, just for testing sake, make the first scene a new empty scene. Just so we can make sure there’s nothing in the scene causing it to break, and it is just settings.

on June 11, 2019

I worked! I tried just changing the settings that you suggested without building an empty scene and I was able to load my main scene and play the game! Thanks for your help.

Show more replies
  • Liked by
Reply
Cancel