Sprite gets cut by invisible line in the middle of camera frustrum – is it a bug?

Updated on October 31, 2017 in [A] 2D
Share on Facebook0Tweet about this on TwitterShare on Google+0Share on Reddit0
2 on October 27, 2017

Hi,

Imagine a line in the exact middle of a camera. If I place sprites on top of it and apply rotation, physics, any kind of movement or force, or even if they stand still, this line visually cuts them. Camera`s ortographic size is 5.68 and aspect ratio is 9:16, 100PPU., but it actually happens even if I change cam size, sprite resolution or PPU and so forth.

For example, if I move an object from left part of the screen to the right, when object reaches middle of the camera frustrum this line moves along the object, till object bypassess the middle point of camera. I will attach some screenshots to make it easier to understand.

 

https://ibb.co/nkpC0m – cam line

https://ibb.co/hHXh0m – distortion example

https://ibb.co/g60VmR – distortion example

When sprite is placed outside of this line, everything is ok. How can I fix it?

Thank you.

P.S. I provided links to screenshots, because attaching images isn`t working (maybe I did smth wrong).

  • Liked by
Reply
1 on October 29, 2017

 

Did you put the line there? I’d recommend checking the properties of this line to see if it is a setting that is causing it, which i happen to find most likely.

Let me know how you get on, if nothing works, I’ll look further into it for you.

Thus, because it’s been two days, if you were able to fix it, please list how you did it so that if others encounter it there is a solution for them too.

Have a nice day!

on October 31, 2017

Hi, sorry for being late.

I illustrated this line in photoshop so that people can understand what middle line of the camera Im talking about. In reality there is no red line and nothing, but camera itself. I still can`t fix it.

Show more replies
  • Liked by
Reply
Cancel