Shader Graph Error – The Current render Pipeline is not compatible with this master node

Updated on September 28, 2018 in [A] Shaders
Share on Facebook0Tweet about this on TwitterShare on Google+0Share on Reddit0
3 on July 28, 2018

I started learning shader graphs but i am getting this weird issue when i create PBR Graph shader

Can anyone please help me how to fix this?

  • Liked by
Reply
0 on August 14, 2018
  • Liked by
Reply
Cancel
0 on August 16, 2018

Shader Graph is only useable with the LightWeightRenderPipeline unfortunately. This means you start a new project with this pipeline in it (easy way) or you just try to set it for your current project (hard way).

here is a tutorial from unity:

YouTube

 

  • Liked by
Reply
Cancel
0 on September 28, 2018

1) Download the new Lightweight Render Pipeline from the Package Manager

2) Right Click in the asset folder and Create -> Rendering -> Lightweight pipeline asset-> name it anything.

3) Goto Edit -> Project Settings -> Graphics then Drag and drop the Pipeline asset you created onto the Scriptable Render Pipeline Settings (1st item).

  • Liked by
Reply
Cancel