Multiplayer FPS Tutorial Issue – Player Thruster Animation Blend Not Working

Updated on May 30, 2018 in [A] Tutorials
Share on Facebook0Tweet about this on TwitterShare on Google+0Share on Reddit0
1 on May 30, 2018

Hello everyone,

I have been following along Brackeys wonderful Multiplayer FPS tutorial without any issues until midway through E09, where the animation blend is supposed to transition between the MoveForward, Idle, and MoveBackward animations for the Player/Graphics/PlayerModel/Thrusters, https://youtu.be/T_03RZTdIkk?t=1115

I have re-watched this section of the tutorial and followed the instructions many times, but when I drag the Blend Tree slider, the thrusters do not rotate in the preview in the bottom right corner like they do in the tutorial video.

I’ve confirmed that I setup the 3 animations correctly by viewing the MoveForward, Idle, and MoveBackward animations in the Animation pane, where I see that Thrusters : Rotation, Rotation.x is set to -90, -40, 0, respectively.

I have added the 3 animations as motion fields to the blend tree as per the tutorial’s instructions, yet nothing happens when I preview the player model and drag the slider left and right.

I’m really stuck and would sincerely appreciate some help so I can continue working on this awesome tutorial!

PS: If it helps, I’m on Unity version 2017.4.1f1

  • Liked by
Reply
0 on May 30, 2018

Sure enough, I continued with the tutorial despite not seeing the animation in the preview window, and when I added the code to PlayerController.cs to make the animations work in-game, the animations work.

If anyone else doesn’t see the animation blend work in the preview window, don’t worry, it will work in-game once you continue and add the code, at least as of Unity version 2017.4.1f1.

  • Liked by
Reply
Cancel