Material Emission Total White Issue

Updated on April 18, 2016 in [A] Shaders
Share on Facebook0Tweet about this on TwitterShare on Google+0Share on Reddit0
3 on April 18, 2016

I have this Soda Machine that is supposed to emit light in a totally dark scene. There is some plastic where the logo is. That’s the part of the Soda Machine that is supposed to emit light. I have a emission map to tell the material where to emit light.
The issue is that when i crank up the emission, rather than showing the texture, it’s just showing a color. If i wan’t to see the effect of the emission, i’ll have to crank it up so high that the texture becomes completely white. I wan’t it to be like unlit where you can actually see the texture.
I have come up with some ideas for a solution.
* Find a way to make the texture not turn completely white when turning up the emission and just make it shine in the dark.
* Blend shaders: I don’t know if this is possible, but if there were a way to blend the standard shader with a unlit shader based a black and white image.
* Remodel and seperate the emission part from the rest of the model and have two shaders. This is not something I wan’t to do, but if there’s no other way…
I don’t know.

  • Liked by
2 on April 18, 2016

Hey there!
So yeah, when an emission get too bright it goes white.
What you might want to do is to enable HDR on your camera. This might help a bit.
Creating your own shader won’t help much because emission still remains emission…
I think you want to look into bloom. This is an image effect that make bright things bleed a bit of light.

Unity has it in it’s effects package on the asset store.

on April 18, 2016

Sorry, but this is not the issue. The issue is that when i crank up the emission, I can’t see the texture. I wan’t to still be able to see the texture when I make it brighter. I don’t know if this is even possible though. -_-

on April 18, 2016

Well that’s the problem. You can’t make it be brighter without it going white. But with bloom you can make it appear brighter.

Show more replies
  • Liked by