Issue after creating player prefab

Updated on October 24, 2018 in [A] Brackeys Courses
Share on Facebook0Tweet about this on TwitterShare on Google+0Share on Reddit0
3 on October 24, 2018

So I was following an old Brackeys tutorial I was on the 14th episode of said tutorial adding the AI, in the mid of it, I decided to create a Player prefab and delete my current player from the hierarchy, afterwards i added the prefab and kept following the tutorial not testing if the prefab worked.

After finishing said tutorial I went for some testing and the player was broken, this happens https://i.gyazo.com/fc2936b5b41cb1944188774c9dbe0ced.mp4 I can’t jump and it is stuck on the jumping animation, also the AI wont recognize the Player as Player, just saying it can’t find it. I can’t undo what it’s done and i have no clue how to fix this.

Thank you for your time

  • Liked by
Reply
2 on October 24, 2018

Did you fix the references that are made through the inspector? The drag and drop action you did with the player. I think its unlinked or you made a prefab from a unfinisched version. If you make a prefab from the player, and then edit things, you have to save the changed to the prefab.

on October 24, 2018

Hey, I managed to fix everything but the fact it’s stuck in the jumping animation, and the fact it doesn’t jump at all, what might be the issue here?

on October 24, 2018

I managed to fix everything I had to update what is ground on the prefab to account the obstacles. Thank you for your time. Thread can be closed.

Show more replies
  • Liked by
Reply
Cancel