How to edit: button.interactable = false

Updated on May 30, 2018 in Unity
Share on Facebook0Tweet about this on TwitterShare on Google+0Share on Reddit0
2 on May 30, 2018

The problem I am having is that when I change my button to 

btns[firstGuessIndex].interactable = false;

the button becomes transparent. Is there a way to stop this from happening. I have tried using

btns[firstGuessIndex].interactable = false;
btns[firstGuessIndex].image.color = new Color(0, 0, 0, 255);

but the transparency still remains

  • Liked by
Reply
1 on May 30, 2018

That’s because the image (and its transparency) are being affected by the button.

On the button component, you should see 4 color areas. Those are for modifying the button’s image in its different states.

 

What you want to do to fix your issue, is click on the Disabled Color one, and just crank the alpha slider up to 255 (full opacity)

 

on May 30, 2018

Awesome, thanks for your help!

Show more replies
  • Liked by
Reply
Cancel